Training courses

Kernel and Embedded Linux

Bootlin training courses

Embedded Linux, kernel,
Yocto Project, Buildroot, real-time,
graphics, boot time, debugging...

Bootlin logo

Elixir Cross Referencer

#	$NetBSD: list,v 1.46 2018/10/01 17:50:08 martin Exp $

SRCDIRS	bin sbin external/bsd/less/bin usr.bin usr.sbin

PROG	bin/cat		usr/bin/strings
PROG	bin/chmod
PROG	bin/cp
PROG	bin/dd
PROG	bin/df
PROG	bin/ed
PROG	bin/ln
PROG	bin/ls
PROG	bin/mkdir
PROG	bin/mt
PROG	bin/mv
PROG	bin/pax		usr/bin/tar
PROG	bin/pwd
PROG	bin/rm
PROG	bin/sh
PROG	bin/stty
PROG	bin/sync

PROG	sbin/chown	bin/chgrp
PROG	sbin/disklabel
PROG	sbin/dmesg
PROG	sbin/fsck
PROG	sbin/fsck_ffs
PROG	sbin/ifconfig
PROG	sbin/init
PROG	sbin/mknod
PROG	sbin/mount
PROG	sbin/mount_cd9660
PROG	sbin/mount_ffs
PROG	sbin/mount_msdos
PROG	sbin/mount_nfs
PROG	sbin/newfs	sbin/mount_mfs
PROG	sbin/ping
PROG	sbin/raidctl
PROG	sbin/reboot	sbin/halt
PROG	sbin/restore	sbin/rrestore
PROG	sbin/route
PROG	sbin/shutdown
PROG	sbin/slattach
PROG	sbin/swapctl
PROG	sbin/umount

PROG	usr/bin/ftp
PROG	usr/bin/gzip	usr/bin/gzcat usr/bin/gunzip
PROG	usr/bin/less	usr/bin/more
PROG	usr/bin/sed
PROG	usr/bin/tip
PROG	usr/bin/tset

PROG	usr/sbin/bad144
PROG	usr/sbin/chroot
PROG	usr/sbin/installboot

# init invokes the shell as -sh
ARGVLN	sh -sh

SPECIAL	gzip		srcdir	distrib/utils/x_gzip
SPECIAL	ping		srcdir	distrib/utils/x_ping

LIBS	-ledit -lutil -lcurses -lterminfo -lrmt -lcrypt -ll -lm -lz -llzma -lprop

# we need the boot blocks /usr/mdec
COPY	${DESTDIR}/usr/mdec/boot		usr/mdec/boot
COPY	${DESTDIR}/usr/mdec/bootxx_ffs		usr/mdec/bootxx_ffs
COPY	${DESTDIR}/usr/mdec/bootxx_ffsv2	usr/mdec/bootxx_ffsv2

# various files that we need in /etc for the install
COPY	${NETBSDSRCDIR}/etc/group		etc/group
COPY	${NETBSDSRCDIR}/etc/master.passwd	etc/master.passwd
COPY	${NETBSDSRCDIR}/etc/netconfig		etc/netconfig
COPY	${DISTRIBDIR}/common/protocols		etc/protocols
COPY	${DISTRIBDIR}/common/services		etc/services

CMD	${TOOL_PWD_MKDB} -L -d . etc/master.passwd
MTREE	./etc/pwd.db	type=file uname=root gname=wheel mode=0644
MTREE	./etc/spwd.db	type=file uname=root gname=wheel mode=0600

# and the common installation tools
COPY	${DISTRIBDIR}/utils/script-installer/dot.commonutils .commonutils
COPY	${DISTRIBDIR}/utils/script-installer/dot.instutils   .instutils

# and the installation tools
COPY	${CURDIR}/dot.profile			.profile

# old-style installation tools
COPY	${CURDIR}/install.sh			install		555
COPY	${CURDIR}/upgrade.sh			upgrade		555

# and the install notes
COPY	${INSTALLNOTES}				INSTALL.more