# $NetBSD: evbarm.conf,v 1.33.2.1 2019/12/08 14:35:10 martin Exp $
# evbarm shared config
#
image=$HOME/${board}.img
MACHINE=evbarm
extra=48 # spare space
init=32
boot=$((192 - ${init}))
ffsoffset=$(( (${init} + ${boot}) / 2 ))m
size=0 # autocompute
msdosid=12
mkdir -p ${mnt}/boot
make_label_evbarm() {
# compute all sizes in terms of sectors
local totalsize=$(( ${newsize} * 1024 * 2 / 512 ))
local bootsize=$(( ${boot} * 1024 ))
local bootoffset=$(( ${init} * 1024 ))
local asize=$(( ${totalsize} - ${bootsize} - ${bootoffset} ))
local aoffset=$(( ${bootoffset} + ${bootsize} ))
local bps=512
local spt=32
local tpc=64
local spc=2048
local cylinders=$(( ${totalsize} / ${spc} ))
cat << EOF
type: SCSI
disk: STORAGE DEVICE
label: fictitious
flags: removable
bytes/sector: ${bps}
sectors/track: ${spt}
tracks/cylinder: ${tpc}
sectors/cylinder: ${spc}
cylinders: ${cylinders}
total sectors: ${totalsize}
rpm: 3600
interleave: 1
trackskew: 0
cylinderskew: 0
headswitch: 0 # microseconds
track-to-track seek: 0 # microseconds
drivedata: 0
8 partitions:
# size offset fstype [fsize bsize cpg/sgs]
a: ${asize} ${aoffset} 4.2BSD ${fsize} ${bsize} 0 #
c: ${totalsize} 0 unused 0 0 #
e: ${bootsize} ${bootoffset} MSDOS #
EOF
}
make_fstab_evbarm_normal() {
cat > ${mnt}/etc/fstab << EOF
# NetBSD /etc/fstab
# See /usr/share/examples/fstab/ for more examples.
ROOT.a / ffs rw,noatime 1 1
ROOT.e /boot msdos rw 1 1
kernfs /kern kernfs rw
ptyfs /dev/pts ptyfs rw
procfs /proc procfs rw
tmpfs /var/shm tmpfs rw,-m1777,-sram%25
EOF
}
# From Richard Neswold's:
# http://rich-tbp.blogspot.com/2013/03/netbsd-on-rpi-minimizing-disk-writes.html
# Also for the postfix stuff below
make_fstab_evbarm_minwrites() {
cat > ${mnt}/etc/fstab << EOF
# NetBSD /etc/fstab
# See /usr/share/examples/fstab/ for more examples.
ROOT.a / ffs rw,log,noatime,nodevmtime 1 1
ROOT.e /boot msdos rw 1 1
kernfs /kern kernfs rw
ptyfs /dev/pts ptyfs rw
procfs /proc procfs rw
tmpfs /tmp tmpfs rw,-s32M
tmpfs /var/log tmpfs rw,union,-s32M
tmpfs /var/run tmpfs rw,union,-s1M
tmpfs /var/mail tmpfs rw,union,-s10M
tmpfs /var/spool/postfix tmpfs rw,union,-s20M
tmpfs /var/db/postfix tmpfs rw,union,-s1M
tmpfs /var/chroot tmpfs rw,union,-s10M
tmpfs /var/shm tmpfs rw,-m1777,-sram%25
EOF
}
make_fstab_evbarm() {
if $minwrites; then
make_fstab_evbarm_minwrites
else
make_fstab_evbarm_normal
fi
echo "./etc/fstab type=file uname=root gname=wheel mode=0644" \
>> "$tmp/selected_sets"
# Missing mount points from fstab
echo "./proc type=dir uname=root gname=wheel mode=0755" \
>> "$tmp/selected_sets"
echo "./kern type=dir uname=root gname=wheel mode=0755" \
>> "$tmp/selected_sets"
}
customize_evbarm() {
if $minwrites; then
mkdir ${mnt}/etc/postfix
(umask 022
sed -e 's/fifo/unix/' < ${release}/etc/postfix/master.cf > \
${mnt}/etc/postfix/master.cf)
fi
cp ${release}/etc/rc.conf ${mnt}/etc/rc.conf
cat >> ${mnt}/etc/rc.conf << EOF
dev_exists() {
if /sbin/drvctl -l \$1 >/dev/null 2>&1 ; then
printf YES
else
printf NO
fi
}
rc_configured=YES
hostname=${board}
no_swap=YES
savecore=NO
sshd=YES
dhcpcd=YES
ntpd=YES
ntpd_flags="-g"
creds_msdos=YES
creds_msdos_partition=/boot
EOF
if $resize; then
cat >> ${mnt}/etc/rc.conf << EOF
resize_disklabel=YES
resize_root=YES
resize_root_flags="-p"
resize_root_postcmd="/sbin/reboot -n"
EOF
fi
echo "./etc/rc.conf type=file uname=root gname=wheel mode=0644" \
>> "$tmp/selected_sets"
mkdir ${mnt}/etc/rc.d
for _f in resize_disklabel creds_msdos; do
cp ${DIR}/files/${_f} ${mnt}/etc/rc.d/${_f}
echo "./etc/rc.d/${_f} type=file uname=root gname=wheel mode=0555" \
>> "$tmp/selected_sets"
done
if [ ! -f ${release}/dev/MAKEDEV ]; then
echo ${PROG}: Missing ${release}/dev/MAKEDEV 1>&2
exit 1
fi
echo "${bar} running MAKEDEV ${bar}"
${HOST_SH} ${release}/dev/MAKEDEV -s all | sed -e 's:^\./:\./dev/:' \
>> "$tmp/selected_sets"
echo "${bar} fixing up permissions"
echo "./boot type=dir uname=root gname=wheel mode=0755" \
>> "$tmp/selected_sets"
}